<!DOCTYPE html>
<html lang="tr">
<head>
<meta charset="UTF-8"/>
<link rel="pingback" href="/xmlrpc.php" />
<meta name="viewport" content="width=device-width, initial-scale=1">
<title>Nesne Yönelimli Programlama Nedir ? - Technolat</title>
<!-- All in One SEO Pack 2.5 by Michael Torbert of Semper Fi Web Designob_start_detected [-1,-1] -->
<meta property="og:title" content="Nesne Yönelimli Programlama Nedir ?" />
<meta property="og:type" content="article" />
<meta property="og:url" content="https://www.technolat.com/nesne-yonelimli-programlama-nedir-15764/" />
<meta property="og:image" content="https://www.technolat.com/wp-content/uploads/2018/10/asfasfsaf.jpg" />
<meta property="og:site_name" content="Teknoloji Haberleri ve Teknoloji İçerikleri - Technolat" />
<meta property="og:description" content="Nesne Yönelimli Programlama (Object Oriented Programming/OOP) , programlama konusunda çığır açan, uzman-acemi bütün programcıların işini kolaylaştıran bir teknolojidir. Özellikle bu işle uğraşanların yakından bildiği gibi Nesneye Yönelik Programlama normal bir işlemi daha hızlı. Daha profesyonel bir dil ile kodlarınızı sınıflar içerisine yazıyorsunuz ve sınıflardan türeyen nesneler üzerinden kodlarınızı çağırıyorsanız Nesne Yönelimli Programlama yapıyorsunuz anlamına geliyor. Nesneye Yönelik Programlama, bir çok yazılım dersinde ilk önce anlatılan teknolojilerden bir tanesidir. Çünkü Nesneye Yönelik Programlama&#039;nın temelini oturtmak sizi çok fazla yükten kurtaracaktır. Nesneye Yönelik Programlama&#039;nın 3 ana prensibi vardır. Bunlar Encapsulation, Polymorphism, Inheritance&#039;dır. Encapsulation Nedir ? Encapsulation türkçe Kapsülleme anlamına gelmektedir. Bu prensip nesne hakkındaki bilgi ve yapılacak işlemlerini ortaya koyar. Herhangi bir nesne düşünelim örneğin şemsiye; şemsiyenin rengi," />
<meta property="article:tag" content="yazılım" />
<meta property="article:publisher" content="Technolat" />
<meta property="article:published_time" content="2018-10-23T14:27:29Z" />
<meta property="article:modified_time" content="2018-10-23T14:33:11Z" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:site" content="technolat.com" />
<meta name="twitter:domain" content="technolat" />
<meta name="twitter:title" content="Nesne Yönelimli Programlama Nedir ?" />
<meta name="twitter:description" content="Nesne Yönelimli Programlama (Object Oriented Programming/OOP) , programlama konusunda çığır açan, uzman-acemi bütün programcıların işini kolaylaştıran bir teknolojidir. Özellikle bu işle uğraşanların yakından bildiği gibi Nesneye Yönelik Programlama normal bir işlemi daha hızlı. Daha profesyonel bir dil ile kodlarınızı sınıflar içerisine yazıyorsunuz ve sınıflardan türeyen nesneler üzerinden kodlarınızı çağırıyorsanız Nesne Yönelimli Programlama yapıyorsunuz anlamına geliyor. Nesneye Yönelik Programlama, bir çok yazılım dersinde ilk önce anlatılan teknolojilerden bir tanesidir. Çünkü Nesneye Yönelik Programlama&#039;nın temelini oturtmak sizi çok fazla yükten kurtaracaktır. Nesneye Yönelik Programlama&#039;nın 3 ana prensibi vardır. Bunlar Encapsulation, Polymorphism, Inheritance&#039;dır. Encapsulation Nedir ? Encapsulation türkçe Kapsülleme anlamına gelmektedir. Bu prensip nesne hakkındaki bilgi ve yapılacak işlemlerini ortaya koyar. Herhangi bir nesne düşünelim örneğin şemsiye; şemsiyenin rengi," />
<meta name="twitter:image" content="https://www.technolat.com/wp-content/uploads/2018/10/asfasfsaf.jpg" />
<meta itemprop="image" content="https://www.technolat.com/wp-content/uploads/2018/10/asfasfsaf.jpg" />
<!-- /all in one seo pack -->
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="Technolat &raquo; Nesne Yönelimli Programlama Nedir ? yorum beslemesi" href="https://www.technolat.com/nesne-yonelimli-programlama-nedir-15764/feed/" />
<link rel='stylesheet' id='main-css-css'  href='//www.technolat.com/wp-content/cache/wpfc-minified/kmoi0p6o/owcf.css' type='text/css' media='all' />
<link rel='https://api.w.org/' href='https://www.technolat.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.technolat.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.technolat.com/wp-includes/wlwmanifest.xml" /> 
<link rel='prev' title='Kombi Hata Kodları İçin Servis Müdahalesi' href='https://www.technolat.com/kombi-hata-kodlari-icin-servis-mudahalesi-15756/' />
<link rel='next' title='AİLENİZLE YAPABİLECEĞİNİZ 8 MÜTHİŞ HAFTA SONU PLANI' href='https://www.technolat.com/ailenizle-yapabileceginiz-8-muthis-hafta-sonu-plani-15777/' />
<meta name="generator" content="WordPress 4.8.1" />
<link rel="canonical" href="https://www.technolat.com/nesne-yonelimli-programlama-nedir-15764/" />
<link rel='shortlink' href='https://www.technolat.com/?p=15764' />
<link rel="alternate" type="application/json+oembed" href="https://www.technolat.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.technolat.com%2Fnesne-yonelimli-programlama-nedir-15764%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://www.technolat.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.technolat.com%2Fnesne-yonelimli-programlama-nedir-15764%2F&#038;format=xml" />
<link rel="amphtml" href="https://www.technolat.com/nesne-yonelimli-programlama-nedir-15764/amp/"><link rel="icon" href="https://www.technolat.com/wp-content/uploads/2017/02/technolat-ikon-150x150.jpg" sizes="32x32" />
<link rel="icon" href="https://www.technolat.com/wp-content/uploads/2017/02/technolat-ikon-300x300.jpg" sizes="192x192" />
<link rel="apple-touch-icon-precomposed" href="https://www.technolat.com/wp-content/uploads/2017/02/technolat-ikon-300x300.jpg" />
<meta name="msapplication-TileImage" content="https://www.technolat.com/wp-content/uploads/2017/02/technolat-ikon-300x300.jpg" />
<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<script>
(adsbygoogle = window.adsbygoogle || []).push({
google_ad_client: "ca-pub-4151890769147889",
enable_page_level_ads: true
});
</script>
<script src="https://cdn.onesignal.com/sdks/OneSignalSDK.js" async=""></script>
<script>
var OneSignal = window.OneSignal || [];
OneSignal.push(function() {
OneSignal.init({
appId: "3aa30f6a-4588-4732-971c-5b350a8b2992",
autoRegister: true,
notifyButton: {
enable: true,
},
});
});
</script>
</head>
<body>
<header id="header">
<div class="yeniUst">
<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- technolat_ANAUst -->
<ins class="adsbygoogle"
style="display:inline-block;width:970px;height:250px"
data-ad-client="ca-pub-4151890769147889"
data-ad-slot="4569311656"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script>
</div>
<div id="mySidenav" class="sidenav">
<a href="javascript:void(0)" class="closebtn" onclick="closeNav()">&times;</a>
<div class="menu-anabaslik-container"><ul id="menu-anabaslik" class="menu"><li id="menu-item-1538" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1538"><a href="https://www.technolat.com/teknoloji-haberleri/"><i class="fa fa-newspaper-o"></i> TEKNOLOJİ HABERLERİ</a></li>
<li id="menu-item-10072" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-10072"><a href="https://www.technolat.com/videolar/"><i class="fa fa-youtube-play"></i> VİDEOLAR</a></li>
<li id="menu-item-1539" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1539"><a href="https://www.technolat.com/liste/"><i class="fa fa-list-ul"></i> LİSTE</a></li>
<li id="menu-item-1540" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1540"><a href="https://www.technolat.com/rehber/"><i class="fa fa-book"></i> REHBER</a></li>
<li id="menu-item-6803" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-6803"><a href="http://forum.technolat.com/"><i class="fa fa-th-large"></i> FORUM</a></li>
</ul></div>    </div>
<div class="container">
<div class="row">
<div class="logo col s12 l3">
<a href="https://www.technolat.com"><img width="150" height="39" src="https://www.technolat.com/wp-content/uploads/2016/09/logo.png" alt="technolat-logo" /></a>
<i class="fa fa-list" onclick="openNav()"></i>
</div>
<nav class="main-menu col s12 l9">
<div class="menu-anabaslik-container"><ul id="menu-anabaslik-1" class="menu"><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1538"><a href="https://www.technolat.com/teknoloji-haberleri/"><i class="fa fa-newspaper-o"></i> TEKNOLOJİ HABERLERİ</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-10072"><a href="https://www.technolat.com/videolar/"><i class="fa fa-youtube-play"></i> VİDEOLAR</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1539"><a href="https://www.technolat.com/liste/"><i class="fa fa-list-ul"></i> LİSTE</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1540"><a href="https://www.technolat.com/rehber/"><i class="fa fa-book"></i> REHBER</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-6803"><a href="http://forum.technolat.com/"><i class="fa fa-th-large"></i> FORUM</a></li>
</ul></div>            </nav>
</div>
</div>
<nav class="second-nav">
<div class="container">
<div class="row flex">
<div class="bottom-menu col s12 l9">
<div class="menu-ana-container"><ul id="menu-ana" class="menu"><li id="menu-item-11" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-11"><a href="https://www.technolat.com/mobil/"><i class="fa fa-mobile" aria-hidden="true"></i> Mobil</a></li>
<li id="menu-item-1172" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1172"><a href="https://www.technolat.com/internet/"><i class="fa fa-wifi" aria-hidden="true"></i> İnternet</a></li>
<li id="menu-item-4307" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-4307"><a href="https://www.technolat.com/giyilebilir-teknoloji/"><i class="fa fa-user-plus" aria-hidden="true"></i> Giyilebilir Teknoloji</a></li>
<li id="menu-item-12" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-12"><a href="https://www.technolat.com/oyun/"><i class="fa fa-gamepad" aria-hidden="true"></i> Oyun</a></li>
<li id="menu-item-7" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-7"><a href="https://www.technolat.com/bilim/"><i class="fa fa-flask" aria-hidden="true"></i> Bilim</a></li>
<li id="menu-item-80" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-80"><a href="https://www.technolat.com/otomobil/"><i class="fa fa-car" aria-hidden="true"></i> Otomobil</a></li>
<li id="menu-item-8" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-8"><a href="https://www.technolat.com/donanim/"><i class="fa fa-wrench" aria-hidden="true"></i> Donanım</a></li>
<li id="menu-item-13" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-13"><a href="https://www.technolat.com/yazilim/"><i class="fa fa-code" aria-hidden="true"></i> Yazılım</a></li>
<li id="menu-item-13838" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-13838"><a href="https://www.technolat.com/magazin/"><i class="fa fa-diamond" aria-hidden="true"></i> Magazin</a></li>
<li id="menu-item-2303" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-2303"><a href="https://www.technolat.com/roportaj/"><i class="fa fa-comment" aria-hidden="true"></i> Röportaj</a></li>
</ul></div>                </div>
<div class="top-search col s12 l3">
<form id="search-form" method="get" action="https://www.technolat.com">
<input type="text" name="s" placeholder="Sitede ara..."><input type="submit" value="Ara">
</form>
</div>
</div>
</div>
</nav>
<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<script>
(adsbygoogle = window.adsbygoogle || []).push({
google_ad_client: "ca-pub-4151890769147889",
enable_page_level_ads: true
});
</script>
</header>
<section class="container">
<div class="row">
<div class="primary col s12">
<div class="mSosyal">
<a class="facebook external" href="https://www.facebook.com/sharer/sharer.php?u=https://www.technolat.com/nesne-yonelimli-programlama-nedir-15764/" rel="nofollow" target="_blank"><i class="fa fa-facebook"></i></a>
<a data-twittershare href="https://twitter.com/intent/tweet?text=Nesne Yönelimli Programlama Nedir ? https://www.technolat.com/nesne-yonelimli-programlama-nedir-15764/" data-ios-message="{&quot;action&quot;:&quot;share&quot;,&quot;target&quot;:&quot;twitter&quot;,&quot;text&quot;:&quot;Nesne Yönelimli Programlama Nedir ?&quot;,&quot;url&quot;:&quot;https://www.technolat.com/nesne-yonelimli-programlama-nedir-15764/&quot;}" class="twitter external" rel="nofollow" target="_blank"><i class="fa fa-twitter"></i></a>
<a class="googlep" href="#" onclick=" window.open('https://plus.google.com/share?url='+encodeURIComponent(location.href), 'facebook-share-dialog',       'width=596,height=331'); return false;"><i class="fa fa-google-plus"></i> </a>
<a class="whatsapp" href="whatsapp://send?text=https://www.technolat.com/nesne-yonelimli-programlama-nedir-15764/&t=Nesne Yönelimli Programlama Nedir ?" data-action="share/whatsapp/share" target="blank">
<div class="col-xs-3 col-sm-3" style="background-color:#43d854;">
<i class="fa fa-whatsapp fa-2x"></i>
</div></a>
</div>
<section id="content" class="col s12 l8">
<div class="breadcrumbs" typeof="BreadcrumbList" vocab="https://schema.org/">
<!-- Breadcrumb NavXT 6.0.4 -->
<span property="itemListElement" typeof="ListItem"><a property="item" typeof="WebPage" title="Go to Technolat." href="https://www.technolat.com" class="home"><span property="name">Technolat</span></a><meta property="position" content="1"></span> &gt; <span property="itemListElement" typeof="ListItem"><a property="item" typeof="WebPage" title="Go to the Yazılım category archives." href="https://www.technolat.com/yazilim/" class="taxonomy category"><span property="name">Yazılım</span></a><meta property="position" content="2"></span> &gt; <span property="itemListElement" typeof="ListItem"><span property="name">Nesne Yönelimli Programlama Nedir ?</span><meta property="position" content="3"></span>
</div>
<article role="main" itemscope="" itemtype="https://schema.org/NewsArticle" data-prevtitle="Nesne Yönelimli Programlama Nedir ?" data-previmage="https://www.technolat.com/wp-content/uploads/2018/10/asfasfsaf.jpg" data-type="news" data-id="15764" data-url="https://www.technolat.com/nesne-yonelimli-programlama-nedir-15764/" data-title="Nesne Yönelimli Programlama Nedir ?" data-description="Nesne Yönelimli Programlama (Object Oriented Programming/OOP) , programlama konusunda çığır açan, uzman-acemi bütün programcıların işini kolaylaştıran bir teknolojidir. Özellikle bu işle uğraşanların yakından bildiği gibi Nesneye Yönelik Programlama normal bir işlemi daha hızlı. " data-keywords="" data-amp="https://www.technolat.com/nesne-yonelimli-programlama-nedir-15764/amp/">
<meta itemprop="mainEntityOfPage" content="https://www.technolat.com/nesne-yonelimli-programlama-nedir-15764/">
<meta itemprop="inLanguage" content="tr-TR">
<meta itemprop="genre" content="news" name="medium">
<meta itemprop="keywords" content=""/>
<meta itemprop="datePublished" content="23/10/2018 14:27"/>
<meta itemprop="dateModified" content="23/10/2018 14:33"/>
<div class="details"><span class="date"><strong>23.10.2018 14:27</strong> </span><div class="author"><p itemprop="author" itemscope itemtype="https://schema.org/Person">	<span itemprop="name"><a href="https://www.technolat.com/author/sevketkabatas/" title="Şevket Kabataş tarafından yazılan yazılar" rel="author">Şevket Kabataş</a></span></p></div>
</div>
<div class="title" >
<h1 itemprop="headline">Nesne Yönelimli Programlama Nedir ?</h1>
</div>
<div class="excerpt" itemprop="description"><p>Nesne Yönelimli Programlama (Object Oriented Programming/OOP) , programlama konusunda çığır açan, uzman-acemi bütün programcıların işini kolaylaştıran bir teknolojidir. Özellikle bu işle uğraşanların yakından bildiği gibi Nesneye Yönelik Programlama normal bir işlemi daha hızlı. </p></div>	
<div class="mustReklam">
<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<ins class="adsbygoogle" style="display:block" data-ad-client="ca-pub-4151890769147889" data-ad-slot="6127732450" data-ad-format="link"></ins>
<script>(adsbygoogle=window.adsbygoogle||[]).push({});</script>
</div>	<div class="post-img"><img width="616" height="345" src="https://www.technolat.com/wp-content/uploads/2018/10/asfasfsaf-616x345.jpg" class="attachment-single_img size-single_img wp-post-image" alt="" srcset="https://www.technolat.com/wp-content/uploads/2018/10/asfasfsaf-616x345.jpg 616w, https://www.technolat.com/wp-content/uploads/2018/10/asfasfsaf-150x84.jpg 150w" sizes="(max-width: 616px) 100vw, 616px" /></div>
<figure itemprop="image" itemscope="" itemtype="https://schema.org/ImageObject">
<meta itemprop="url" content="https://www.technolat.com/wp-content/uploads/2018/10/asfasfsaf.jpg">
<meta itemprop="width" content="613">
<meta itemprop="height" content="345">
</figure>
<div class="sosyal">
<a class="facebook" href="#"   onclick=" window.open('https://www.facebook.com/sharer/sharer.php?u='+encodeURIComponent(location.href), 'facebook-share-dialog',       'width=596,height=331'); return false;"><i class="fa fa-facebook"></i></a>
<a class="twitter" href="#"  onclick=" window.open('https://twitter.com/home?status=+Nesne Yönelimli Programlama Nedir ? '+encodeURIComponent(location.href), 'facebook-share-dialog',       'width=596,height=331'); return false;"><i class="fa fa-twitter"></i></a>
<a class="googlep" href="#" onclick=" window.open('https://plus.google.com/share?url='+encodeURIComponent(location.href), 'facebook-share-dialog',       'width=596,height=331'); return false;"><i class="fa fa-google-plus"></i></a>
<script src="https://apis.google.com/js/platform.js"></script>
<div class="g-ytsubscribe" data-channelid="UCVGBb-uofs7r4bN63uoj_mQ" data-layout="full" data-count="default"></div>
<a class="pinterest" href="#" onclick=" window.open('https://www.pinterest.com/pin/create/bookmarklet/?url=https%3A%2F%2Fwww.technolat.com%2Fnesne-yonelimli-programlama-nedir-15764%2F&media=https%3A%2F%2Fwww.technolat.com%2Fwp-content%2Fuploads%2F2018%2F10%2Fasfasfsaf.jpg&is_video=false&description=Nesne+Y%C3%B6nelimli+Programlama+%28Object+Oriented+Programming%2FOOP%29+%2C+programlama+konusunda+%C3%A7%C4%B1%C4%9F%C4%B1r+a%C3%A7an%2C+uzman-acemi+b%C3%BCt%C3%BCn+programc%C4%B1lar%C4%B1n+i%C5%9Fini+kolayla%C5%9Ft%C4%B1ran+bir+teknolojidir.+%C3%96zellikle+bu+i%C5%9Fle+u%C4%9Fra%C5%9Fanlar%C4%B1n+yak%C4%B1ndan+bildi%C4%9Fi+gibi+Nesneye+Y%C3%B6nelik+Programlama+normal+bir+i%C5%9Flemi+daha+h%C4%B1zl%C4%B1.+Daha+profesyonel+bir+dil+ile+kodlar%C4%B1n%C4%B1z%C4%B1+s%C4%B1n%C4%B1flar+i%C3%A7erisine+yaz%C4%B1yorsunuz+ve+s%C4%B1n%C4%B1flardan+t%C3%BCreyen+nesneler+%C3%BCzerinden+kodlar%C4%B1n%C4%B1z%C4%B1+%C3%A7a%C4%9F%C4%B1r%C4%B1yorsan%C4%B1z+Nesne+Y%C3%B6nelimli+Programlama+yap%C4%B1yorsunuz+anlam%C4%B1na+geliyor.+%5B%26hellip%3B%5D'); return false;"><i class="fa fa-pinterest"></i></a>	
</div>
<div class="content" itemprop="articleBody">
<h3>Nesne Yönelimli Programlama (Object Oriented Programming/OOP) , programlama konusunda çığır açan, uzman-acemi bütün programcıların işini kolaylaştıran bir teknolojidir.</h3>
<h3>Özellikle bu işle uğraşanların yakından bildiği gibi Nesneye Yönelik Programlama normal bir işlemi daha hızlı.</h3>
<p>Daha profesyonel bir dil ile kodlarınızı sınıflar içerisine yazıyorsunuz ve sınıflardan türeyen nesneler üzerinden kodlarınızı çağırıyorsanız Nesne Yönelimli Programlama yapıyorsunuz anlamına geliyor. Nesneye Yönelik Programlama, bir çok yazılım dersinde ilk önce anlatılan teknolojilerden bir tanesidir. Çünkü Nesneye Yönelik Programlama’nın temelini oturtmak sizi çok fazla yükten kurtaracaktır. Nesneye Yönelik Programlama’nın 3 ana prensibi vardır. Bunlar Encapsulation, Polymorphism, Inheritance’dır.</p>
<img class="alignnone size-medium wp-image-15766 alignleft" src="https://www.technolat.com/wp-content/uploads/2018/10/asfasfsaf-300x199.jpg" alt="" width="300" height="199" srcset="https://www.technolat.com/wp-content/uploads/2018/10/asfasfsaf-300x199.jpg 300w, https://www.technolat.com/wp-content/uploads/2018/10/asfasfsaf-150x100.jpg 150w, https://www.technolat.com/wp-content/uploads/2018/10/asfasfsaf-257x170.jpg 257w, https://www.technolat.com/wp-content/uploads/2018/10/asfasfsaf.jpg 734w" sizes="(max-width: 300px) 100vw, 300px" />
<div class="rich-content-editor_text__jwLWP rich-content-editor_elementSpacing__2hXa7 _14s5m blog-post-text-font blog-post-text-color">
<div class="public-DraftStyleDefault-block public-DraftStyleDefault-ltr"><strong>Encapsulation Nedir ? </strong>Encapsulation türkçe Kapsülleme anlamına gelmektedir. Bu prensip nesne hakkındaki bilgi ve yapılacak işlemlerini ortaya koyar. Herhangi bir nesne düşünelim örneğin şemsiye; şemsiyenin rengi, boyutu ve örneğin açılması gibi özelliklerin tamamı Encapsulation prensibinde ortaya koyulur.</div>
<div></div>
</div>
<div class="rich-content-editor_text__jwLWP rich-content-editor_elementSpacing__2hXa7 _14s5m blog-post-text-font blog-post-text-color">
<div class="public-DraftStyleDefault-block public-DraftStyleDefault-ltr"><strong>Inheritance Nedir ? </strong>Inheritance türkçe kalıtım anlamına geliyor. Kalıtım prensibi nesnelerin bir nesne oluşturulmasını ortaya koyar. Biraz önce ki şemsiye örneği üzerinden devam edersek. Şemsiye için bir sopa, demir vs. gerekiyor bunun gibi nesnelerden oluşan nesneleri ortaya koyar.</div>
</div>
<div class="rich-content-editor_text__jwLWP rich-content-editor_elementSpacing__2hXa7 _14s5m blog-post-text-font blog-post-text-color">
<div class="public-DraftStyleDefault-block public-DraftStyleDefault-ltr">Polymorphism Nedir ? Polymorphism türkçe çok biçimlilik anlamına gelmektedir. Çok biçimlilik prensibi bir işlemin veya metodun bir çok nesne tarafından kullanılabilmesi anlamına geliyor. Yani örneğin bir arabayı düşünürsek ayna ve tekerlek farklı iki nesnedir. Dönme işlemi ikisi içinde geçerli olarak kullanılabilir.</div>
<div></div>
</div>
<div class="rich-content-editor_text__jwLWP rich-content-editor_elementSpacing__2hXa7 _14s5m blog-post-text-font blog-post-text-color">
<div class="public-DraftStyleDefault-block public-DraftStyleDefault-ltr">Nesneye Yönelik Programlama, programcıların o dağınık ve anlaşılmaz yapılarını tamamen ortadan kaldırıyor diyebiliriz. Bu teknoloji sizlere yapacağınız işin parçalara ayırıp organize bir şekilde hareket etmenizi sağlar. Yani bir araba yapacaksanız, tekerlek, ayna, iskelet, direksiyon, pedal vs. her şeyi ayrı ayrı yapıp bir bütün haline getirmenizi sağlıyor. Bu sayede siz tekerlekteki sorunu ararken ayna, direksiyona vs. boşuna bakmamış bunların kodlarını incelemekten kurtulmuş oluyorsunuz. Aynı zamanda eğer yeni bir şey eklemek isterken de yine sizleri istediğiniz yere götürüyor. Ne kadar parçalayabilirim derseniz bu size kalmış. Aynı zamanda OOP( Object Oriented Programming) sayesinde kodlarınız sizin dışınızda gören kişiler tarafından da kolayca algılanabilir hale gelmektedir.</div>
</div>
</p><div><span style="color: #ff9900;"><script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- icBaglanti -->
<ins class="adsbygoogle"
style="display:block"
data-ad-client="ca-pub-4151890769147889"
data-ad-slot="2930818970"
data-ad-format="link"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script>
</span></div><div style="text-align:center">
<!-- <script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
technolaticeriKKare
<ins class="adsbygoogle"
style="display:inline-block;width:300px;height:250px"
data-ad-client="ca-pub-4151890769147889"
data-ad-slot="2825807657"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script>
-->
<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<ins class="adsbygoogle"
style="display:block"
data-ad-format="autorelaxed"
data-ad-client="ca-pub-4151890769147889"
data-ad-slot="1103114441"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script>
</div></div>
<div class="details"><span class="cat" >Kategoriler:<strong>
<a href="https://www.technolat.com/yazilim/">Yazılım</a> </strong></span></div>
<div class="details"><span class="tags" >Etiketler: <strong></strong></span></div>
<div itemprop="publisher" itemscope itemtype="https://schema.org/Organization">
<div itemprop="logo" itemscope itemtype="https://schema.org/ImageObject">
<meta itemprop="url" content="https://www.technolat.com/technolat-logo-amp-251x59.jpg" />
<meta itemprop="width" content="251" />
<meta itemprop="height" content="59" />
</div>
<meta itemprop="name" content="Technolat" />
<meta itemprop="sameAs" content="https://www.facebook.com/technolat" />
<meta itemprop="sameAs" content="https://twitter.com/technolat" />
<meta itemprop="sameAs" content="https://plus.google.com/+Technolatcom/" />
<meta itemprop="sameAs" content="https://www.instagram.com/technolat/" />
<meta itemprop="sameAs" content="https://www.instagram.com/technolat/" />
<meta itemprop="sameAs" content="https://www.youtube.com/channel/UCVGBb-uofs7r4bN63uoj_mQ" />
<meta itemprop="sameAs" content="https://www.linkedin.com/company/technolat-com" />
</div>
</article>
<div class="related-posts">
</div>
<div id="disqus_thread"></div>
<div class="yorumReklam">
Technolat olarak <a href="https://www.technolat.com/nesne-yonelimli-programlama-nedir-15764/">Nesne Yönelimli Programlama Nedir ?</a> başlıklı yazımızda sizlere "<a href="https://www.technolat.com/nesne-yonelimli-programlama-nedir-15764/">Nesne Yönelimli Programlama Nedir ?</a>" ile ilgili bilgileri sunmayı amaçladık. Bu başlık ile ilgili düşüncelerinizi yukarıdaki alanda yorum yaparak dile getirebilir ve diğer yorumlarıda okuyarak inceleyip "<a href="https://www.technolat.com/nesne-yonelimli-programlama-nedir-15764/">Nesne Yönelimli Programlama Nedir ?</a>" ile ilgili katkıda bulunabilirsiniz.
</div>
</section>
<aside id="sidebar" class="col s12 l4">
<aside id="rss-2" class="widget widget_rss"><h6 class="widget-title"><a class="rsswidget" href="https://forum.technolat.com/kategori/-/index.rss"><img class="rss-widget-icon" style="border:0" width="14" height="14" src="https://www.technolat.com/wp-includes/images/rss.png" alt="RSS" /></a> <a class="rsswidget" href="https://forum.technolat.com/">Forumdan Son Konular</a></h6><ul><li><a class='rsswidget' href='https://forum.technolat.com/konu/hangi-siteyi-kullanarak-cinden-alisveris-yapmaliyim.448/'>Hangi siteyi kullanarak çinden alışveriş yapmalıyım ?</a></li><li><a class='rsswidget' href='https://forum.technolat.com/konu/paykasa-nereden-alinir.1164/'>Paykasa Nereden Alınır</a></li><li><a class='rsswidget' href='https://forum.technolat.com/konu/paykasa-ve-astropaycard-al.1163/'>Paykasa ve Astropaycard Al</a></li><li><a class='rsswidget' href='https://forum.technolat.com/konu/paykasa-ve-astropaycard-al.1162/'>Paykasa ve Astropaycard Al</a></li><li><a class='rsswidget' href='https://forum.technolat.com/konu/paykasa-ve-astropaycard-al.1161/'>Paykasa ve Astropaycard Al</a></li><li><a class='rsswidget' href='https://forum.technolat.com/konu/paykasa-astropay-kart-satisi.1160/'>Paykasa Astropay Kart Satışı</a></li></ul></aside><aside id="tabs_widget-2" class="widget widget_tabs_widget">
<div class="tab-post col s12"><!-- technolatSagKutu
<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<ins class="adsbygoogle"
style="display:inline-block;width:300px;height:250px"
data-ad-client="ca-pub-4151890769147889"
data-ad-slot="4344884059"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script></div>
-->
<div class="posts-tabs">
<ul>
<li class="tab1 active">POPÜLER</li><li class="tab2">YENİ</li>
</ul>
<div class="tabs-container"><div class="popular-posts-tab">
<ul class="wpp-list">
<div class="tab-post col s12">
<div class="tab-post-img col s5"><a href="https://www.technolat.com/samsung-gear-vr-uyumlu-telefonlar-3100/" title="Samsung Gear VR Uyumlu Telefonlar" target="_self"><img src="https://www.technolat.com/wp-content/uploads/wordpress-popular-posts/3100-featured-66x60.jpg" width="66" height="60" title="Samsung Gear VR Uyumlu Telefonlar" alt="Samsung Gear VR Uyumlu Telefonlar" class="wpp-thumbnail wpp_cached_thumb wpp_featured"/></a></div>
<div class="tab-post-meta col s7">
<span><a href="https://www.technolat.com/samsung-gear-vr-uyumlu-telefonlar-3100/">Samsung Gear VR Uyumlu Telefonlar</a></span>
<span class="details">27 Temmuz 2017</span>
</div>
</div>
<div class="tab-post col s12">
<div class="tab-post-img col s5"><a href="https://www.technolat.com/iphonea-bilgisayardan-fotograf-aktarma-3209/" title="iPhone&#8217;a Bilgisayardan Fotoğraf Aktarma" target="_self"><img src="https://www.technolat.com/wp-content/uploads/wordpress-popular-posts/3209-featured-66x60.png" width="66" height="60" title="iPhone&#8217;a Bilgisayardan Fotoğraf Aktarma" alt="iPhone&#8217;a Bilgisayardan Fotoğraf Aktarma" class="wpp-thumbnail wpp_cached_thumb wpp_featured"/></a></div>
<div class="tab-post-meta col s7">
<span><a href="https://www.technolat.com/iphonea-bilgisayardan-fotograf-aktarma-3209/">iPhone&#8217;a Bilgisayardan Fotoğraf Aktarma</a></span>
<span class="details">14 Nisan 2016</span>
</div>
</div>
<div class="tab-post col s12">
<div class="tab-post-img col s5"><a href="https://www.technolat.com/android-sebeke-sorunu-cozumu-2852/" title="Android Şebeke Sorunu Çözümü" target="_self"><img src="https://www.technolat.com/wp-content/uploads/wordpress-popular-posts/2852-featured-66x60.jpg" width="66" height="60" title="Android Şebeke Sorunu Çözümü" alt="Android Şebeke Sorunu Çözümü" class="wpp-thumbnail wpp_cached_thumb wpp_featured"/></a></div>
<div class="tab-post-meta col s7">
<span><a href="https://www.technolat.com/android-sebeke-sorunu-cozumu-2852/">Android Şebeke Sorunu Çözümü</a></span>
<span class="details">17 Mart 2016</span>
</div>
</div>
<div class="tab-post col s12">
<div class="tab-post-img col s5"><a href="https://www.technolat.com/internetten-bedava-sms-gonderme-nasil-yapilir-7102/" title="İnternetten Bedava SMS Gönderme Nasıl Yapılır?" target="_self"><img src="https://www.technolat.com/wp-content/uploads/2016/09/bedava-sms-616x345.png" width="66" height="60" title="İnternetten Bedava SMS Gönderme Nasıl Yapılır?" alt="İnternetten Bedava SMS Gönderme Nasıl Yapılır?" class="wpp-thumbnail wpp_def_noPath wpp_featured"/></a></div>
<div class="tab-post-meta col s7">
<span><a href="https://www.technolat.com/internetten-bedava-sms-gonderme-nasil-yapilir-7102/">İnternetten Bedava SMS Gönderme Nasıl Yapılır?</a></span>
<span class="details">26 Ağustos 2017</span>
</div>
</div>
<div class="tab-post col s12">
<div class="tab-post-img col s5"><a href="https://www.technolat.com/buzdolabi-alinirken-nelere-dikkat-edilmeli-6947/" title="Buzdolabı Alınırken Nelere Dikkat Edilmeli?" target="_self"> <img src="https://www.technolat.com/wp-content/uploads/2016/08/buzdolabi-alinirken-nelere-dikkat-edilmeli.jpg" width="66" height="60" title alt class="wpp-thumbnail wpp_imgeditor_error wpp_featured"/></a></div>
<div class="tab-post-meta col s7">
<span><a href="https://www.technolat.com/buzdolabi-alinirken-nelere-dikkat-edilmeli-6947/">Buzdolabı Alınırken Nelere Dikkat Edilmeli?
</a></span>
<span class="details">11 Haziran 2018</span>
</div>
</div>
</ul></div><div class="latest-posts-tab">
<div class="tab-post col s12">
<div class="tab-post-img col s5">
<a href="/ailenizle-yapabileceginiz-8-muthis-hafta-sonu-plani-15777/"></a>
</div>
<div class="tab-post-meta col s7">
<span><a href="/ailenizle-yapabileceginiz-8-muthis-hafta-sonu-plani-15777/">AİLENİZLE YAPABİLECEĞİNİZ 8 MÜTHİŞ HAFTA SONU PLANI</a></span>
<span class="details">23 Ekim 2018</span>
</div>
</div>
<div class="tab-post col s12">
<div class="tab-post-img col s5">
<a href="/nesne-yonelimli-programlama-nedir-15764/"><img width="66" height="60" src="https://www.technolat.com/wp-content/uploads/2018/10/asfasfsaf-66x60.jpg" class="attachment-sidebar_latest size-sidebar_latest wp-post-image" alt="" /></a>
</div>
<div class="tab-post-meta col s7">
<span><a href="/nesne-yonelimli-programlama-nedir-15764/">Nesne Yönelimli Programlama Nedir ?</a></span>
<span class="details">23 Ekim 2018</span>
</div>
</div>
<div class="tab-post col s12">
<div class="tab-post-img col s5">
<a href="/kombi-hata-kodlari-icin-servis-mudahalesi-15756/"><img width="66" height="60" src="https://www.technolat.com/wp-content/uploads/2018/10/kombi-66x60.jpeg" class="attachment-sidebar_latest size-sidebar_latest wp-post-image" alt="" /></a>
</div>
<div class="tab-post-meta col s7">
<span><a href="/kombi-hata-kodlari-icin-servis-mudahalesi-15756/">Kombi Hata Kodları İçin Servis Müdahalesi</a></span>
<span class="details">8 Ekim 2018</span>
</div>
</div>
<div class="tab-post col s12">
<div class="tab-post-img col s5">
<a href="/tekne-kiralama-15754/"></a>
</div>
<div class="tab-post-meta col s7">
<span><a href="/tekne-kiralama-15754/">TEKNE KİRALAMA</a></span>
<span class="details">7 Ekim 2018</span>
</div>
</div>
<div class="tab-post col s12">
<div class="tab-post-img col s5">
<a href="/vichy-urunleri-ile-cildinizi-korumaya-alin-15748/"></a>
</div>
<div class="tab-post-meta col s7">
<span><a href="/vichy-urunleri-ile-cildinizi-korumaya-alin-15748/">Vichy Ürünleri İle Cildinizi Korumaya Alın</a></span>
<span class="details">21 Eylül 2018</span>
</div>
</div>
</div>
</div></div>
<div class="clear"></div>
<div style="margin-top:3px;">
<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<ins class="adsbygoogle"
style="display:block"
data-ad-format="autorelaxed"
data-ad-client="ca-pub-4151890769147889"
data-ad-slot="1103114441"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script>
</div>
</aside></aside>
</div>
</div>
</section>
<footer id="footer">
<div class="container">
<div class="row">
<div class="menu-sosyal-container"><ul id="menu-sosyal" class="menu"><li id="menu-item-8315" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-8315"><a href="https://www.facebook.com/technolat/" class="external" rel="nofollow" target="_blank"><i class="fa fa-facebook"></i></a></li>
<li id="menu-item-8317" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-8317"><a href="https://twitter.com/technolat" class="external" rel="nofollow" target="_blank"><i class="fa fa-twitter"></i></a></li>
<li id="menu-item-8318" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-8318"><a href="https://www.youtube.com/channel/UCVGBb-uofs7r4bN63uoj_mQ" class="external" rel="nofollow" target="_blank"><i class="fa fa-youtube-play"></i></a></li>
<li id="menu-item-9350" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-9350"><a href="https://plus.google.com/b/108996499310420438869/108996499310420438869" class="external" rel="nofollow" target="_blank"><i class="fa fa-google"></i></a></li>
</ul></div>
<div class="footer-menu col s12 l7"><div class="menu-alt-container"><ul id="menu-alt" class="menu"><li id="menu-item-27" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-27"><a href="/hakkimizda/">Hakkımızda</a></li>
<li id="menu-item-30" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-30"><a href="/kunye/">Künye</a></li>
<li id="menu-item-29" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-29"><a href="/kullanim-kosullari/">Kullanım Koşulları</a></li>
<li id="menu-item-28" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-28"><a href="/gizlilik-politikasi/">Gizlilik Politikası</a></li>
<li id="menu-item-76" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-76"><a href="/alinti-kosullari/">Alıntı Koşulları</a></li>
</ul></div><div class="footer-copy col s12 l5">Tüm hakları saklıdır. Technolat &copy; 2018.<br>Web Tasarım: <a href="https://netger.net/">Netger Reklam Ajansı Erzurum</a>
<a href="http://rotatercume.com" title="Tercüme Bürosu">Tercüme Bürosu</a>
<a href="https://www.ikincielalinir.net/ikinci-el-bilgisayar-alan-yerler">ikinci El Bilgisayar Alan Yerler</a>
</div>
<a href="//www.dmca.com/Protection/Status.aspx?ID=218eb7b4-4721-4841-9cf9-7019b8dd7995" title="DMCA.com Protection Status" class="dmca-badge external" rel="nofollow" target="_blank"> <img src="//images.dmca.com/Badges/dmca-badge-w200-5x1-09.png?ID=218eb7b4-4721-4841-9cf9-7019b8dd7995" alt="DMCA.com Protection Status"></a> <script src="//images.dmca.com/Badges/DMCABadgeHelper.min.js"> </script>
</div>
</div>
</div>
</footer>
<script>
(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
})(window,document,'script','https://www.google-analytics.com/analytics.js','ga');
ga('create', 'UA-80198895-1', 'auto');
ga('send', 'pageview');
</script>
<link rel='stylesheet' id='wp-pagenavi-css'  href='//www.technolat.com/wp-content/cache/wpfc-minified/2xxu8ukd/owcf.css' type='text/css' media='all' />
<script type='text/javascript'>
/* <![CDATA[ */
var countVars = {"disqusShortname":"technolat"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.technolat.com/wp-content/plugins/disqus-comment-system/public/js/comment_count.js?ver=3.0.15'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var embedVars = {"disqusConfig":{"integration":"wordpress 3.0.15"},"disqusIdentifier":"15764 https:\/\/www.technolat.com\/?p=15764","disqusShortname":"technolat","disqusTitle":"Nesne Y\u00f6nelimli Programlama Nedir ?","disqusUrl":"https:\/\/www.technolat.com\/nesne-yonelimli-programlama-nedir-15764\/","postId":"15764"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.technolat.com/wp-content/plugins/disqus-comment-system/public/js/comment_embed.js?ver=3.0.15'></script>
<script type='text/javascript' src='https://www.technolat.com/wp-content/themes/technolat/assets/js/includes.js?ver=1'></script>
<script type='text/javascript' src='https://www.technolat.com/wp-content/themes/technolat/assets/js/main.js?ver=1'></script>
<script type='text/javascript' src='https://www.technolat.com/wp-content/plugins/wp-fastest-cache/js/toolbar.js?ver=1526991848'></script>
<script type='text/javascript' src='https://www.technolat.com/wp-includes/js/jquery/jquery.js?ver=1.12.4'></script>
<script type='text/javascript' src='https://www.technolat.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<script type='text/javascript' src='https://www.technolat.com/wp-includes/js/jquery/ui/core.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='https://www.technolat.com/wp-includes/js/jquery/ui/widget.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='https://www.technolat.com/wp-includes/js/jquery/ui/position.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='https://www.technolat.com/wp-includes/js/jquery/ui/menu.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='https://www.technolat.com/wp-includes/js/jquery/ui/selectmenu.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='https://www.technolat.com/wp-includes/js/wp-embed.min.js'></script>
</body>
</html><!-- Page generated by LiteSpeed Cache 2.3.1 on 2018-10-23 20:07:10 --><!-- WP Fastest Cache file was created in 0.70381307601929 seconds, on 23-10-18 20:07:10 --><!-- need to refresh to see cached version -->